• 1. London, UK
  • 2. New York, NY
  • 3. Sydney, Australia
  • 4. Melbourne, Australia
  • 5. Moscow, Russia
  • 6. Singapore
  • 7. Paris, France
  • 8. Chicago, IL
  • 9. Hong Kong
  • 10. Houston, TX

Wednesday, October 19, 2005

 

Exchange Server 2003 SP2 and IMF

Posted by Bharat Suneja at 2:06 PM

Before you install Exchange Server 2003 SP2 you need to uninstall Intelligent Message Filter (IMF). When you do this, the settings from the SMTP virtual server where you allowed filtering are also removed.

After SP installation if you go to Intelligent Message Filtering settings (Global Settings -> Message Delivery -> Properties -> Intelligent Message Filtering tab) and setup IMF with same settings as earlier, that alone does not reactivate IMF.

You still need to enable IMF from the SMTP virtual server properties -> General tab -> Advanced Edit (see screenshot, Flash demo of IMFv1 and IMFv2 settings - not entirely intuitive location for these settings, imo) and check "Apply Intelligent Message Filter" - just as you need to check the relevant options for recipient filter, connection filter, sender filter, and the new option of applying SenderID filter.

Labels: , ,

16 Comments:

January 19, 2006 10:27 AM
Blogger Pete said...

Give this man a medal! How come he's the only person on the whole net to mention that the IMF enabling can be found this way? Courtesy of MS, the official Exchange FAQ sites, Daniel Petri et al, I've spent hours puzzling over EMS, looking for the missing IMF option under the virtual SMTP server, re-installing SP2, re-installing IMF, editing the registry, applying the MS IMF update . . . you name it, I've tried it.
Thank you!

 
January 24, 2006 1:24 AM
Blogger BJohns said...

Thank you Bharat. Like Peter, I too have spent a couple of hours trying to figure this out. Thanks to your blog I can put this one to bed !

 
February 18, 2006 3:18 AM
Blogger lingrovecs said...

Thank you. I fell into a similar trap installing IMF 2 onto a SP2 install.

Searching MS site reveals nothing useful. In fact it finds some really 'un-useful' stuff. There doesn't seem to be anything on the IMF built into SP2. Searches for IMF only reveal the older IMF product.

IMF would not be installed without your post. I've got 4 more customers to do now !

Many thanks

 
March 20, 2006 1:49 PM
Blogger [email protected] said...

Thanks so much !!!

I fell into this with the Windows Limit of Exchange space... only reason i pumped in EXPS2.

What a joke... can they of made it any more diffucult!

Thanks so much.

 
May 30, 2006 9:18 AM
Anonymous Anonymous said...

To uninstall Intelligent Message Filter, use Add or Remove Programs in Control Panel. The account that was used to install Intelligent Message Filter must also be used to uninstall the filter. No other accounts will see Intelligent Message Filter in Add or Remove Programs.

 
June 7, 2006 8:05 PM
Anonymous Anonymous said...

I have to agree with everyone above... thanks so much for this guide.

 
June 17, 2006 1:54 PM
Anonymous Anonymous said...

I agree. This info was exactly what I needed!!!

 
June 28, 2006 2:16 AM
Anonymous chris said...

Thank you too. Just to tell you, this saved me hours.

Great. I'm glad, people like you share their experiences to help all of us.

 
July 17, 2006 6:39 PM
Anonymous Anonymous said...

Thanks a lot!!!!!!!!

 
September 6, 2006 11:45 AM
Blogger Herzengel said...

Hallo
After I installed "Best Practice Analyzer Tool" (EX 2003 SP2) in the Repport was written that I had to reinstall Exchange again.
After done this while installing a message appeard to tell me I have to install the Service Pack again. I tried to install SP2 but I could'nt because of an older IMF Version had been installed. But it is'nt it does not appear in Add/Remove Progs. How can I uninstall IMF. Thanks for any Postings.

Stefano

 
September 6, 2006 8:11 PM
Blogger Bharat Suneja said...

Install IMF version 1 again, then remove it from Add/Remove Programs.

 
September 9, 2006 3:41 AM
Anonymous ammonyte579 said...

Thanks for the IMF tip, I nearly had heart failure trying to find it! It is now sept 2006 and mickeysoft syill haven't updated their information about the location of the configuration!!!!!

 
September 30, 2006 9:59 AM
Anonymous bob said...

how long would it take to setup 20 users on exchange from the begginning. server is already loaded but have not setup active directory?

 
September 30, 2006 5:49 PM
Blogger Bharat Suneja said...

Do you mean you've already loaded Windows OS on the server? Setting up AD shouldn't take too long, and neither should Exchange. The actual setup of software or user accounts isn't what takes more time, imo - the planning is what does.

For a small environment it shouldn't be such a concern - you need to determine the domain name you'll use for your AD, if it'll be the same domain name as your external/registered domain name you use for a web site/email, et al.

There's plenty of documentation for planning & deploying AD and Exchange available on microsoft.com.

 
October 20, 2006 11:08 AM
Anonymous Anonymous said...

Thanks for the tip...but the Intelligent message filtering is still not under the SMTP folder in System Manager for me.

I did restart the SMTP service. Do I just need to reboot? Or are there other services that need restarting?

Thanks!!!
Brian

 
September 21, 2009 2:52 AM
Anonymous Anonymous said...

Thks bharat... I got a query whn m trying to upgrade Exch CCR in 2003 to Sp2 my information store service goes down in mailbox.... can you help me out with the procedure....

I tried upgrading in both 2003 n 2008... Win 2008 is sucessful after enabling IPv6 but wht to do in 2003 its full of issues...

I made a test setup thn strt upgrading it with hubcas.... i got error while finalizing setup... thn got error aftr upgrading the fst node of MAilbox CCR. Whn i trasfer roles the Information stores goes down....

 

Post a Comment

Links to this post:

Create a Link

<< Home