Move mailbox issue: disconnected mailbox remains on source mailbox Store

by Bharat Suneja

This came up earlier today in a newsgroup post. You move a mailbox from one mailbox Store to a mailbox Store on another server – either between two Exchange Server 2003/2000 servers, or between an Exchange Server 2003/2000 and an Exchange Server 2007 server. The mailbox moves successfully, the user can access it on the server it is moved to.

However, the mailbox is not purged from the source mailbox Store. It has a small size, and Exchange System Manager reports the number of items as 0. The mailbox is disconnected – it has a red x icon super-imposed, but ESM does not allow you to purge it or connect it to another user.

Running the mailbox cleanup agent on the Store does not change anything.

To be able to purge the mailbox from the target Store, try to move the mailbox back to that (original) Store. Move Mailbox will notify you that the mailbox already exists on the destination Store, and prompt you to purge it. Choose the option to purge.

The hotfix mentioned in KBA 940012 resolves this issue.

{ 5 comments… read them below or add one }

Anonymous August 1, 2007 at 2:30 pm

This does work but am I going to have to do this for all 400+ mailboxes that I have to move from Ex2003 to Ex2007?


Bharat Suneja August 1, 2007 at 2:52 pm

Not likely – do you anticipate all mailbox moves to end up in a disconnected state? :)


Anonymous November 23, 2007 at 8:34 am

Might help E2k3 SP2 servers who have this issue.


Jeff February 1, 2008 at 2:04 pm

same issue here but one of the mailboxes has around 100 items on the old server. is there any way to merge these messages with the mailbox on new server?


Gil July 15, 2008 at 12:21 pm

Go to AD>Find related user>Press on remove exchaange attributes>Purge the mailbox that you can’t delete>Reconnect mailbox back to user.


Leave a Comment

Previous post:

Next post: